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Drawing a BPMN 2.0 Business Process Diagram

1.

Create a new project by selecting Project > New from the application toolbar. In the New
Project window, enter Tutorial as the project name and click Create Blank Project.

Let's create a model first. Select View > Project Browser from the application toolbar.

Project UeXceler Diagram View Team Tools Modeling Window Help
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Open the Model Structure page in the Project Browser.

Diagrams Model Structe My Recent Team Recent

Click the New Model button at the top of the model list on the left-hand side.
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5. Name the model Sales and click OK to confirm.

| References | Project Management | Quiality | Comments

'8
Values | Constraints | Diagrams I Traceability :
General Chidren | Relations | ChartRelations | Stereotypes "
Name:|Sa|es |
Description:

6. You can create pools directly under the Sales model without using a diagram. Let's try it. Right-

click on the Sales model and select Model Element > New Model Element... from the popup
menu.

w T Tutorial

Model Element

New Model Element... »
Chikl l

a Open Sales Specification...
Rename... . Class
Show Link... & Model
Show View... - Package
Stereotypes »

7. You can search for the model you want to create in the New Model Element window. Enter Po
in the Model element type text field to search for Pool.

Model element type :
Model element name :

Description :

=
Br=- =

Open specification after create
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8. Enter Customer as the Model element name.

Model element type :

Model element name :

Description :

B-=-=-F-B-WF+-@-n

Poal

Customer

Open specification after create

Tutorial

9. Uncheck Open specification after create and click OK to continue.

10. Repeat these steps to create the pools Bidder, Manufacturer, and Supplier.

11. Right-click on the Sales model and select Sub Diagrams > New Diagram... from the popup

menu.

w T Tutorial

w Elements (4)

Model Element » | Bidder
Open Sales Specification...
Rename...
Show Link...
Show View...
Stereotypes 3
| Sub Diagrams 3 ! micid
_ New Model | MNew Diagram...
- Model Trnsitor Existing Diagrams...
-ﬁE Transit From 3
B} Transit To 3
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12. Inthe New Diagram window, select Business Process Diagram and click Next. Keep the
diagram name as provided and click OK to create the diagram.

called "Brainstorm™. When the meeting ends, you can organize the notes

~
and derive a diagram from them.

Business Process Diagram 3

Model business workflow with the use of OMG BPMN (Business Process Mode}
and Notation).

Chart Diagram

Define the relationships between model elements in project.

Class Diagram

Design object model, persistence model for Hibernate ORM and REST API
with classes, their attributes, operations and inter-relationship.

Communication Diagram

Model the relationships between objects. Communication Diagram focuses
on teling whether a relationship exists between objects. It does not tell their
order and how objects interact with each other.

L

| Next || canel |

13. You can now start creating the business process diagram. First, let's create a start event. Select

the Start Event tool from the diagram toolbar and click on the empty area of the business
process diagram.

Sales & Sales

<Unspedfied=| -,

r-'bo

e Xeyerchony |

14. Now, click on the start event and drag out the Resource Catalog icon.

[ ] L]
:O:
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15. Release the mouse button on the blank area of the diagram and select Choreography Task
from the Resource Catalog.

o—O®Oo 0 ¢
5§80 -

Choreography Task
16. Enter Order Request as the name of the choreography task and press Enter to confirm.

0

O—b Order Request

17. Right-click on Order Request and select Open Specification....

n | |
O—pomr Request L

- E Qpen Specification... I,\\, Enter
Stereotypes r
Edit
& Cut
Copy 4
Delete 4

18. Select the Customer pool as Participant 1.

< Choreography Task Specification “
References Project Management Quiality Comments ﬁ
Taooed Values Constraints Diagrams Traceability
General Procedures Message Flows Stereotypes ]:E
Name: Order Request
ID: BPOS
Participant 1: |d <unspecified > v
Participant 2: [ <unspedfied>
= Bidder

Initiating participant:

Loop type: 1 Manufacturer

Description: = Supplier

19. Select the Manufacturer pool as Participant 2.
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20. Select the Customer pool as the Initiating participant.

£+ Choreography Task Specification “
References Project Management Quiality Comments :f
Taooed Values Constraints Diagrams Traceability ~

General Procedures Message Flows Stereotypes T-L.

MName: Order Request

ID: BPOS

Participant 1: 3 Customer W

Participant 2: [ Manufacturer L

Initiating particdpant: 3:I Customer - Sales L

Loop type: <Unspecified = Y]

Description:

21. Click OK to confirm. The Order Request task is now done. You can see that the initiating
participant is shown in the same color as the task, while the non-initiating participant is shown in

gray.
( Customer
O—P Order Request
\ Manufacturer }

22. Let's create a message between Customer and Manufacturer. Click on the Order Request task
and drag out the Resource Catalog icon.

*<

l(._l_ u 1%

=1

e e Resource Catalog
O—-Order Request m

Aanufact @ by
" & -1

23. Release the mouse button above the choreography task and select Message from the Resource
Catalog.

O® 0
B X

< H

=
O

o

Message
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24. Then, select New Message Flow from "Customer" to "Manufacturer” from the popup menu.

Select Message Flow

Mew Message Flow from "Customer” to "Manufacturer”

s

Mew Message Flow from "Manufacturer” to "Customer”
l(_(.;IJSEBI'I'M:H'

O—D Order Request

\ Manufacturer /

25. Enter Order as the name of the message and press Enter to confirm.

Order

£ ; A}
Customer

O—b Order Request

‘\_Manufacturer /

26. Create an Event-based Exclusive Gateway from Order Request. Again, click on Order
Request and drag out the Resource Catalog icon. Release the mouse button in the empty
space of the diagram and select Gateway from the Resource Catalog to create a gateway.

Order

£ : N
Customer

O—I-Ordchcquest — E
=== (@)
O Q%@ B =

Gateway

27. Enter Can Fulfill Order? as the name of the gateway and press Enter to confirm. You can insert
a line break by pressing Alt + Enter.

Order

£ : A}
Customer

O—D Order Request

\Manufacturer / Can Fulfil
Order?
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28. Right-click on the gateway and select Type > Event-Based Exclusive Decision/Merge (XOR).

EZ[I'I

Orde

a Open Specification...
Stereotypes
Model Element Properties
Type
Form Separate Diagram Sub-Process

Form Same Diagram Sub-Process
Edit

Enter

& Cut

Copy
Delete

40000

<Unspecified>

Data-Based Exclusive Decision/Merge (XOR)
Event-Based Exclusive Decision/Merge (XOR) L\\?

Inclusive Decision/Merge (OR)

Complex Decision/Merge

Parallel Fork/Join (AND)

29. Repeat the steps to complete the business process diagram, like this:

( Customer [ Customer )
E Ordcr. P Deliver Order
Order Confiation
: \_Manufacturer / \Manufacturer /
/_'_.\ p—
Customer Customer
No - Order
O—I’ Order Reque st > Reaecton
\Maruiachrer / Can Fulfil Manufacturer
Order?
( Manufacturer
Capacity OK, Procure Parts N
Parts must °
be ordered \_Supplier )/ All Parts
Available?
[ Manufacturer )
Mo Part Auction
LGl All Parts
Obtained?

30. There could be multiple instances of the 'Procure Parts' activity running simultaneously. Let's
represent this by setting the loop type of the Procure Parts task to Multi-Instance Loop. Right-
click on the Procure Parts task and select Open specification... from the popup menu.
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31. Select Multi-Instance Loop for the Loop type combo box.

Standard Loop

£+ Choreography Task Specification
References Project Management Quiality Comments =€
Taooed Values Constraints Diagrams Traceability .
General Procedures Message Flows Stereotypes FE
MName: Procure Parts
ID: BP21
Participant 1: 1 Manufacturer W
Participant 2: [ Supplier v
Initiating participant: | 3 Manufacturer - Sales w
Loop type: <Unspecified = LY
Description: <Unspecified >

32. Click OK to confirm. The Multi-Instance loop marker is now shown in the Procure Parts task.

( Manufacturer
Procure Parts |
1]
\_ Supplier )/

33. Let's create messages between Manufacturer and Bidder on the Part Auction task. Using the
Resource Catalog, create a Message from the Part Auction activity. Select New Message Flow
from "Manufacturer” to "Bidder" from the popup menu.

{ Customer { Customer
Ly y = Deliver Order
Order Confimation
: \_Manufacturer / \Manufacturer /
( Customer (" Customer
No - Order
O—b Order Reque st - Rejoction
L [E L Can Fulfill Manufacturer
Onder?
( Manufacturer n
Capacity OK, Procure Parts - m
Parts must 11 — — o
be ordered \_ Supplier )/ All Parts esmge
Available? Mew Message Flow from "Manufacturer” to "Bidder” %
ﬁ Mew Message Flow from "Bidder” to "Manufacturer”
Mo Part Auction
i All Parts
Obtained?

34. Name the message Part Request.
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35. Repeat the step to create another message to the Part Auction task. This time, select New
Message Flow from "Bidder" to "Manufacturer" during creation. Name the message Part
Response. You can see that the message from Bidder to Manufacturer is in a different color
because Bidder is a non-initiating participant.

Part Request

[ Manufacturer )

-® Part Auction —

\__Bidder J

Part Response

36. The gateways All Parts Available? and All Parts Obtained? in the business process diagram
only model the "false" situation. What about the "true" case? Assuming that the flow should go
back to the Order Confirmation task, we don't want to make the diagram too complicated with
too many connector lines. Let's represent the flow using a pair of intermediate events. Click on
the All Parts Available? gateway and drag out the Resource Catalog icon. Release the mouse
button above the gateway and select Intermediate Event from the Resource Catalog. Enter A
as the name and press Enter.

( Customer ( Customer

Order
Confimation

¥ Deliver Order

O
:er \Manufacturer / \_Manufacturer /
[ Customer (" Customer
No Order
Order R st g
O_b ar Reque: “| Rejection
oL Can Fulfil @ Manufacturer
Order?
A
( Manufacturer
Capacity OK, Procure Parts E
Parts must 1 ParTRoquest Mo
be ordered \__ Supplier )/ All Parts :
Ayailabla? .
( Manufacturer )
Mo Part Auction
\__Bidder All Parts

Obtained?

Part Response

37. Name the connector Yes.

38. Right-click on the intermediate event and select Trigger > Link Trigger.
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39. Repeat the steps to create another link event from the All Parts Obtained? gateway.

e ) ( Customer )
Iz.l Order. B Deliver Order
Order Confimation
: \Manufacturer )/ \Manufacturer /
[ Customer (" Customer )
No Order
Order R st L
O_' er keque “| Rejection
R T Can Fulfil Manufacturer
Order?
( Manufacturer
Capacity OK, Procure Parts EI
Parts must 1
be ordered \__Supplier ) Al Parts Part R‘:?q”‘m
Available? .
( Manufacturer )
Mo Part Auction

\__Bidder J

Part Response

40. Select Link Intermediate Event from the diagram toolbar.

™]

Cuerdar

({Jlo0008

- @ Link Intermediate Event

} @ Signal Intermediate Event

@ Message Intermediate Event

@ Timer Intermediate Event

@ Error Intermediate Event

@ Escalation Intermediate Event
@ Cancel Intermediate Event

@ Compensation Intermediate Event

@ Conditional Intermediate Event

s

@ Multiple Intermediate Event

@ Parallel Multiple Intermediate Event

3]
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41.
Your diagram should now look

like this:

[ Customer

@ .’ Customer )
Order

A

Deliver Order

\ 4

Click on the left-hand side of the Order Confirmation task and name it A. Connect it to the task.

Order Confimation
: \_Manufacturer / \_Manufacturer /
( Customer ( Customer )
No Order
Order R st >
O_’ er Reque "|  Rejection
\Manufactirer / Can Fulfil Manufacturer
Order?
(“Manufacturer ) Yes
Capacity OK, Procure Parts ( ~ .
Parts must 11 Mo

be ordered

42. Create the other messages. Finally, your business process diagram should look like this:

(__Supplier

All Parts

Part Request

Availabla? .
( Manufacturer
Mo Part Auction

\__Bidder _/

Part Response

All Parts
Obtained?

@_.f Customer ) ( Customer
E A Order. = Deliver Order
Order Confimmation
: \_Manufacturer / \_Manufacturer )
/—I—‘\ p—
Customer Conf | s ‘Customer
onfimation No ipment ER
»-
O—I’ Order Request > Reeaton
\Maruiachrer / Can Fulfil u Manufacturer
Order? Part Request
( Manufacturer )
Capacity OK, Procure Parts
Parts must 1 =
Part R st
be ordered Al Parts a ‘?q”c

Resources
1. Complete Project - Tutorial.vpp

Related Links
. Introduction to BPMN

\__Supplier /

Part Response

Available? .
( Manufacturer
Mo Part Auction

\__Bidder /

Part Response
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. How to Define Working Procedures for Business Tasks

Visual Q Paradigm
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