How to Integrate Visual Paradigm with NetBeans? (Installation Guide)

Visual Paradigm enables you to integrate the visual modeling environment with NetBeans, providing full software development life cycle support. By designing your software system in Visual Paradigm, you can generate programming source code from class diagram to an NetBeans project. Also, you can reverse engineer your source code into class models in Visual Paradigm.

NetBeans integration overview
NetBeans integration overview

Installation

First of all, please make sure you have NetBeans 6.7 or above available. To install NetBeans Integration from Visual Paradigm:

  1. In Visual Paradigm, select Window > Integration > IDE Integration... from the toolbar.
  2. Select NetBeans Integration. You can run Visual Paradigm in multiple IDEs. In other words, if you need you can select multiple IDEs here. Click Next.
    Select NetBeans Integration
    Select NetBeans Integration
  3. Specify the folder path of NetBeans. Click Next to start copying files to your IDE.
    Path of NetBeans
    Path of NetBeans
    NOTE: NetBeans integration can only be installed on one NetBeans directory only..
    NOTE: If you cannot find any Visual Paradigm menus in NetBeans after the installation, it could be due to our plug-in failed to be recognized by NetBeans. To solve this problem, please deactivate any plug-in in NetBeans and restart NetBeans.
    You can manage plug-in in NetBeans by selecting Tools > Plugin in NetBeans.

Uninstallation

To remove the installation with an integrated IDE, perform an uninstallation.

  1. In Visual Paradigm, select Window > Integration > IDE Integration... from the toolbar.
  2. Select the radio button Uninstall.
  3. Select NetBeans Integration.
    Select NetBeans integration for uninstallation
    Select NetBeans integration for uninstallation
  4. Click Next.
  5. Click Next for file removal.

Related Resources

The following resources may help you to learn more about the topic discussed in this page.

 
Chapter 3. NetBeans Integration Table of Contents 2. Creating a UML Project in NetBeans
 

Technical Support

Have technical issues or suggestions? Please contact Visual Paradigm Support Team.

Sales Support

Have questions related to registration, licensing or payment? Feel free to contact Visual Paradigm Sales Team.

Discussion Forum

Share your suggestions of opinions at VP Discussion Forum.