Importing Rational Software Architect EMX

Rational Software Architect (RSA) is a modeling and development environment, which leverages UML for architectural design for C++ and Java 2 Enterprise Edition (Java2EE) applications and web services. Import of the RSA file, i.e. the .emx file, is supported in Visual Paradigm, so that users can simply migrate the work from RSA to Visual Paradigm and also perform further modeling on the imported models in Visual Paradigm.

  1. Save your work in Rational.
    A Rational drawing
    A Rational drawing
  2. To import a Rational model into Visual Paradigm, select Project > Import > Rational Model... in the toolbar of Visual Paradigm.
  3. In the Import Rational Software Architect UML Model window, specify the file path of the .emx file and click OK.
  4. Select View > Project Browser in the toolbar. The Diagrams view lists the imported diagram(s). You can then double click on the thumnail to open the diagram.
    Diagram view lists the imported diagram(s)
    Diagram view lists the imported diagram(s)

Related Resources

The following resources may help you to learn more about the topic discussed in this page.

 
Chapter 8. Importing Rational Software Architect File Table of Contents 2. Importing Rational Software Architect DNX into Visual Paradigm
 

Technical Support

Have technical issues or suggestions? Please contact Visual Paradigm Support Team.

Sales Support

Have questions related to registration, licensing or payment? Feel free to contact Visual Paradigm Sales Team.

Discussion Forum

Share your suggestions of opinions at VP Discussion Forum.