Visual Paradigm Toolbars Overview

The toolbar appears at the top of the Visual Paradigm application window. It is a collection of commnoly used buttons and tools, categorized into several function menus. The toolbar is shown by default, but you can collapse it by double clicking on any menu.

The Dash menu


The Dash menu

Visual Paradigm has a lot of features. You often need to switch between menus in order to access the feature you want. Dash menu customizable menu. You can add into the menu the tool buttons that you need to access frequently. With dash menu, you can always stick to one single menu, without the need to switch back and forth.

  • Configure Dash Menu - Add and remove toolbar buttons into Dash menu

The Project menu

The Project tab
The Project menu
  • New - Create a project
  • Open - Open an existing project file either by selecting one from file chooser or from the list of recent opened project
  • Save - Save the opening project
  • Close - Close the opening project
  • Print - Open the Print tool to configure the printing and print
  • Export - Export the project to other supported formats
  • Import - Import project data from an external source
  • Referenced Projects - Add or remove referenced project
  • Properties - Edit the basic project properties like name, author and description

The UeXceler menu

The UeXceler tab
The UeXceler menu


Provide you with access to requirement management features available under UeXceler. The buttons to present on this tab is context sensitive. In general, you can perform the following functions via this tab:

  • Open UeXceler
  • Create and edit user story
  • Insert use case statement
  • Edit use case diagram
  • Manage sprint

The Diagram menu

The Diagram tab
The Diagram menu
  • New - Create a diagram
  • Undo - Roll back undesired changes
  • Redo - Rerun an undone action
  • Copy - Copy the selected shape(s)
  • Paste - Paste the selected shape(s) to the active diagram
  • Select All - Select everything on the active diagram
  • Format - Open the Format tool for configuring the formatting properties of the selected (shapes). These properties include the color and line style of shape/connector.
  • Format Copier - Click once to copy the format of the select shape so that you can apply the format to another shape by clicking on that shape. Double click to lock Format Copier so that you can paste the formatting to multiple shapes
  • Search - Toggle the search bar for searching elements in active diagram.
  • Group - Group the selected shapes
  • Ungroup - Break a group
  • Alignment - Align the selected shapes based on their top, bottom, left or right, or to set their width and/or height to be the same
  • Distribution - Distribute the selected shapes evenly based on various criteria
  • Layout - Quick rearrangement of shapes on the opening diagram
  • Link - Toggle the Link box for you to paste a model element URL there and then visit the URL
  • Jump - Instantly open a model element or diagram by providing its name, or part of its name
  • Bookmarks - Bookmark a shape for quick accessing, or to manage the previously added bookmarks

The View menu

The View menu
The View menu
  • Project Browser - Opens the Project Browser for browsing and accessing the diagrams, model elements and model structure of the opening project.
  • Panes - Several panes are available for accessing different kinds of project data. For instance, the Model Explorer can be used to view model hierarchy, while the Diagram Navigator can be used to find diagrams in ease. You can open a pane here.
  • Layers - Create multiple diagram layers to better categorize the different kinds of shapes
  • Styles - Define the style. Each style carries a set of formatting properties. You can assign a style to a shape to apply those properties to that shape
  • Zoom In - Increase the magnification of the active diagram
  • Zoom Out - Reduce the magnification of the active diagram
  • Zoom 100% - Restore the zoom ratio to 100%, which means, no zooming
  • Zoom to Region - Zoom the diagram to a specific region as set by you
  • Grid - Show, hide and configure the appearance of grid lines on diagram
  • Spell Checker - Enable or disable the spell checking feature, which is capable in verifying the correctness of shape names and descriptions and when a problem found, underline it with a red line
  • Full Screen - Maximize the diagram editor by collapsing the toolbar and hiding the opened panes, if any
  • Model Indicator - Show a small icon on shape body for each these situations: that shape has description filled, has a sub-diagram, has references, is an auxiliary view or is came from a referenced project

The Team menu

The Team menu
The Team menu
  • Login - Login to a version controlling system like VPository and Teamwork Server
  • Commit - Upload the local modifications of your project to server
  • Update - Grab the modifications made by your teammates from server to local
  • Tasifier - Open Tasifier, a task management tool, in Visual Paradigm
  • PostMania - Read the posts made by teammates
  • Visual History - Check out and restore the old revisions of diagrams with the Visual History tool
  • Utilities - Perform operations like branching, tagging, exporting a specific revision, etc

The Tools menu

The Tools tab
The Tools menu
  • Doc. Composer - Produce a document with Doc. Composer, or access its management features.
  • Publish Project - Produce web contents from project using Project Publisher.
  • DB - Generate database from ERD, reverse engineer ERD from database
  • Hibernate - Generate Hibernate ORM code for database application development
  • Code - Generate code from class diagram, reverse engineer UML from code. A number of programming languages are supported

The Modeling menu

The Modeling tab
The Modeling menu
  • Requirement List - Open a list of SysML requirements elements. You can view, edit and create requirements there
  • Storyboard - Perform storyboarding by creating scenarios of wireframes
  • Visual Diff - Compare two diagrams and know their differences
  • Animation - Animate the active diagram. Only available when opening an Activity Diagram, Sequence Diagram or Business Process Diagram
  • Simulation - Open the Simulation panel when the active diagram is a Business Process Diagram
  • Nickname - The nickname feature allows you to define multiple name and description set for your model. You can configure and switch between nicknames here
  • Impact Analysis - Create matrix or chart diagram
  • Glossary - Define project vocabularies with the use of the Glossary tool
  • Profile - Create UML profile

The Window menu

The Window tab
The Window menu
  • New Window - Open a new application window
  • Manage Window - Open another application window, or close non-used window(s)
  • Start Page - Open the start page of the application
  • License Manager - Delete or replace your license
  • Application Options - Configure Visual Paradigm application options
  • Project Options - Configure the options for the opening project
  • Auto-Hide Toolbar - Make the toolbar automatically collapsed when you are editing diagram
  • Configuration - Configure stereotypes, requirements, project management look-ups, user story tags, etc
  • Integration - Install the integration with IDEs such as Eclipse, NetBeans, IntelliJ IDEA and Visual Studio

The Help menu

The Help menu
The Help menu
  • Help - Open the Help contents of Visual Paradigm
  • Mouse Gestures - Check out the various kinds of supported mouse gesture
  • Maintenance - Utility features for maintaining or repairing your project
  • Show Loaded models - View the model elements loaded
  • Customize UI - Hide away non-used UI components
  • Switch Workspace - Restart Visual Paradigm in another workspace
  • Online Support - Visit the Visual Paradigm Support page online to submit your support request
  • Install Plugin - You can add your own functions by developing a plugin. Once developed, installed the plugin here
  • Update - Update your installatsion to latest build
  • About - Show the About window

Related Resources

The following resources may help you learn more about the topic discussed in this page.

 
1. Interface Overview Table of Contents 3. Diagram editor
 

Technical Support

Have technical issues or suggestions? Please contact Visual Paradigm Support Team.

Sales Support

Have questions related to registration, licensing or payment? Feel free to contact Visual Paradigm Sales Team.

Discussion Forum

Share your suggestions of opinions at VP Discussion Forum.